[设为首页] [加入收藏]
您现在的位置:主页 > 4887铁算盘资料 >

苹果曝出“史诗级漏洞”:多款手机可越狱软件更新无法修补

[时间:2019-10-28 03:17来源:未知作者:admin浏览:]

  9月27日,科技网站Wired报道称,该漏洞存在于硬件之上,无法通过苹果的软件升级修复。它影响所有配备A5至A11芯片的苹果设备,这意味着,从iPhone 4S到iPhone X在内,所有2011-2017年出产的苹果手机,大多数型号的iPad,iPod Touch,苹果手表、苹果电视等,都存在这个漏洞。

  这一漏洞被研究者axi0mX于9月27日发布,将其命名为“checkm8”(谐音象棋用语“将军”),并称之为“史诗级漏洞”。它是一个bootrom漏洞,可能使黑客从一个很深的层面进入iOS设备,而苹果无法通过未来的软件更新修补。

  “越狱”是指通过让系统崩溃的方法,以达到让任何软件在设备上都能使用的目的。

  近年来,随着iOS的安全性越来越高,越狱在过去几年的iPhone中已经极为罕见。因此,这一漏洞的发现意义重大,科技网站TheVerge当天报道评价称,“或为多年来iPhone黑客界最大的发展之一”。

  Wired报道介绍,这一漏洞本身不是万能的越狱,而是向研究者提供了一个广泛的基础,白姐玄机网。可以为每一种易受攻击的型号打造定制化的越狱,使得越狱者能够接管该设备,运行苹果通常不允许的软件,还可以对应用软件编程,让应用采取苹果的保护措施不允许的方法进行交互和数据分享。

  axi0mX在接受Wired采访时表示:“这是重要的一天。iOS越狱的最好时光在多年以前,当时的越狱十分普遍,操作简单,方便易得。自从iOS 9推出了之后,越狱随着时间的推移就越来越少,越来越不方便,也不是人人可得了。”

  越狱依据的是苹果“bootrom”中的缺陷,即处理器内存中包含的设备开机时会首先运行的基本代码。Axi0mX通过反向工程,检查苹果公司在2018年夏季对iOS12测试版发布的补丁,发现了bootrom的漏洞。

  由于bootrom是一个系统的底层基础,因此这类漏洞可用于极其强大的越狱,不依赖于特定iOS版本的特定漏洞。即使是老款设备上安装了最新发布的iOS 13系统,它仍然会被影响,因为内部的芯片依旧易受攻击。在“checkm8”发现之前,最近一个iOS已知的bootrom攻击还是在2010的iPhone 4。

  上述报道称,“checkm8”刚刚发现,现在还没有实际上利用它的越狱行为出现,这意味着,黑客不能简单地下载工具、破解设备、下载应用,然后开始对iOS系统进行修改。

  至关重要的是,该漏洞目前还只能通过USB触发。这意味着,每次都必须通过计算机才能启用它,这对实际操作越狱造成了限制。

网站首页香港铁铁算4887正版4887铁算盘资料4887开奖现场结果历史www.0101kj.comwww.55288a.com